Outage

Backbone connection fault between Frankfurt - Helsinki

Status: Resolved
Affected systems: Backbone
Start: 2022-05-23 10:15 UTC+0 Ends on: 2022-05-24 19:31 UTC+0
  • Description
    We are currently experiencing a fault in the backbone connection between Frankfurt and Helsinki. This may lead to brief latency issues. Please bear with us. As soon as more information is available, we will post it here. We apologize for any inconvenience. Thank you for your understanding.

  • Resolved
    The fault has been fixed, traffic has been normalized.
    Last update: 2022-05-24 19:31 UTC+0
  • Investigating
    Recovery of the service is in progress
    Last update: 2022-05-24 05:49 UTC+0
  • Update
    There is currently an ongoing fibercut at our subsea cable. Our cable provider is working on fixing this.
    There is currently no ETA.
    Last update: 2022-05-23 14:09 UTC+0