Outage

Fault report for Hetzner Accounts

Status: Resolved
Affected systems: Accounts
Start: 2026-07-11 14:40 UTC+0 Ends on: 2026-07-11 17:02 UTC+0
  • Description
    There is currently a fault on Hetzner Accounts (https://accounts.hetzner.com) which affects the following features:

    - Update of client data
    - Invoice overview
    - Transaction overview
    - Management of payment data
    - Management of promo codes

  • Resolved
    We have resolved the fault. Thank you for your understanding.
    Last update: 2026-07-11 17:02 UTC+0