Information

Phishing mails using Hetzner's name

Status: Resolved
Affected systems: General
Start: 2021-02-23 06:56 UTC+0 Estimated end: 2021-08-06 10:10 UTC+0
  • Description
    This message is about current phishing emails that use Hetzner's name. (We at Hetzner are not sending the mails. We are aware of them and we are doing what we can to stop them.)

    You should always delete phishing mails as soon as possible. Never click on links in phishing emails.

  • Investigating
    Someone is sending a phishing email with the subject "Service-Aufhängung". Please delete the mail.
    Last update: 2021-08-05 14:25 UTC+0
  • Investigating
    Someone is sending a phishing email with the subject "Ihre Hauptadresse wurde geändert" and "Ihre Postanschrift wurde geändert". Please delete the mail.
    Last update: 2021-02-23 07:00 UTC+0